/var/log/messages

debugging with sixth sense

Docker-ce

自宅メイン端末で確認したところでは導入してるパケジは

1
2
$ dpkg --get-selections|grep docker
docker-engine                                   install

とのことだったのですが、新規導入な debian9 には見当らず。色々探してみるに Docker-CE なるソレを、という情報あり。CE は community edition とのこと。

以下なドキュメントに沿って導入しました。

ハロワは動きました。一般ユーザ権限で docker 起動する方法は以下。

docker-compose

docker-compose は apt で導入しています。

自分メモ

docker-engine のバージョンは 1.11.2 とのことです。

追記

まっさら状態で Debian stretch を導入したマシンで確認してみたら以下でした。

1
2
3
4
5
6
7
$ docker --version
Docker version 17.89.1-ce, build 19e2cf6
$ dpkg --get-selections|grep docker
docker-ce
docker-compose
python-docker
python-dockerpty

Comments